Webbilim.com'da çeşitli içerikler yer almaktadır. Nasıl yapılır, Nasıl içilir v.s. gibi tavsiyelere yer verilmektedir. Kendimiz için güzel gördüğümüz veya olsa iyi olurdu dediğimiz şeyleri sizler için derliyoruz..
antalya escort
Anasayfa / Wordpress / Wordpress Güvenlik / WordPress Güncellemede Gelen functions.php Hatasının Çözümü

WordPress Güncellemede Gelen functions.php Hatasının Çözümü

Merhaba arkadaşlar bu yazımda sizlere 50 milyondan fazla kullanıcıya sahip WordPress’in yeni güncellemesiyle, birçoğumuzun ve kullanıcıların %90’ında meydana gelen uyarı veya hata mesajını düzelteceğiz. Eğer WP güncelleme sonrası yönetici panelinizde (wp-admin) üst kısımda herhangi uyarı veya hata mesajı belirmediyse devamını okumanıza gerek yok.

ÇIKAN UYARI VEYA HATA MESAJI:

Warning: apache_get_modules() has been disabled for security reasons in /home/wp-includes/functions.php on line 4185
Warning: in_array() expects parameter 2 to be array, null given in /home/wp-includes/functions.php on line 4186

SORUNUN KAYNAĞI:

Kullandığınız wordpress sürümünün PHP versiyonu ile sizin kullandığınız PHP versiyondan kaynaklı bir uyumsuzluk.

Bu sorunu maksimum 3 dakika zamanınızı alacak basit bir çözümü var. Hemen çözüme geçelim..

SORUNUN ÇÖZÜMÜ:

Kullandığınız PHP versiyonunu şuan için v5.5 yaptığınızda uyarılar veya hatalar ekranınızı terketmiş olacaktır.

PHP Versiyon Nasıl Değiştirilir?

Standart bir cPanel kullanıyorsanız eğer;

cPanel’e giriş yaptıktan sonra biraz aşağı iniyoruz.

php versiyonu değiştirme

Burada Select PHP Version veya Türkçe çevrilmişse PHP Versionu Seç veya PHP Selector ismiyle bir bağlantı göreceksiniz. Hemen tıklayın.

Sonrasında ise WordPress’in uyumsuz olduğu yani sizin kullanmış olduğunuz PHP versiyonu (şuan için) v5.5 versiyonu ile değiştirerek saniyeler içerisinde sorun ortadan kalkmış olacak.

php versiyonu yükseltme

v5.5 veya istediğiniz sürümü seçip “Set as current”a basmanız yeterli. Küçük bir not: Aşağıdaki Kaydet butonu PHP özelliklerini seçtikten sonra kaydetmeyi sağlıyor, PHP versiyonu değiştirmek ile alakalı değil.

Tekrar WordPress panelinize dönün. Herhangi “ini_get_all()” uyarısı veya hata mesajı görmeyeceksiniz.

Neşeli günler 🙂

Hakkında Hasan

Yıllar önce başladı bu hikaye. O zamanlar mynet kişisel sayfa oluşturmamıza olanak sağlamış biz dururmuyuz? Xat sohbet içeren hoş bir sayfa yapmışım, giren çıkan herşey çok iyi. Webmaster denilen dağarcığın içerisinde kayboldukca eski saf ve temiz sayfalardan eser kalmadı hep daha iyisi daha gelişmişi dedik.. Herşeyin hayırlısı...

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

− İki = 7

WeBBilim.Com